Back to overview
Resolved

Upgrading UpMeet Dashboard

Sep 25, 2026 at 6:03pm UTC  –  Sep 25, 2026 at 9:03pm UTC
Affected services
Marketing Website
UpMeet Dashboard

Resolved
Sep 25, 2026 at 9:03pm UTC

Maintenance ended

Created
Sep 25, 2026 at 6:03pm UTC

We're currently in the process of migrating our dashboard experience from dash.upmeet.me to upmeet.me/dashboard - users may face downtime during this migration. Calls will continue to work as expected and the admin dashboard will remain accessible at dash.upmeet.me until the migration is complete.