Back to overview
Degraded

Website may be affected for some users

Sep 25 at 07:20pm BST
Affected services
Marketing Website
Meeting Rooms - Frontend
Meetings in ClickUp

Resolved
Sep 25 at 07:22pm BST

We believe the issue has been resolved. If this behaviour continues please contact us at team@upmeet.me.

Created
Sep 25 at 07:20pm BST

We're currently switching providers and this has caused security certificates to be renewed and regenerated. This may cause the website to be down for some users.