Back to overview
Downtime

Calls in ClickUp is down.

Jan 21, 2024 at 12:10pm UTC
Affected services
Meetings in ClickUp

Resolved
Jan 21, 2024 at 12:17pm UTC

This has been resolved.

Created
Jan 21, 2024 at 12:10pm UTC

A misconfiguration of our new systems has made ClickUp unable to load our Meet View.